summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-08-29 21:20:51 +0200
committerLudovic Courtès <ludo@gnu.org>2013-08-29 21:58:52 +0200
commita9424c0887f688e812e498a2556df4b1d9218268 (patch)
tree395f024c1dd65db7a393c9dbb906e548b9f41b2f
parent88bd1804a25056591237c4163faeb4e42449244d (diff)
downloadguix-a9424c0887f688e812e498a2556df4b1d9218268.tar.gz
build: Build docs from the top-level Makefile.
This undoes commit 575ed8d ("doc: Create own Makefile.am in subdirectory."),
and fixes a bug whereby "make pdf" or "make ps" wouldn't do anything.

* doc/Makefile.am: Remove.
* doc.am: New file.  Use `-local' rules to build the image.
* Makefile.am: Include it.
* configure.ac: Use `-Woverride' to avoid undesired overridding of
  Automake rules.
-rw-r--r--Makefile.am4
-rw-r--r--configure.ac2
-rw-r--r--doc.am (renamed from doc/Makefile.am)27
3 files changed, 19 insertions, 14 deletions
diff --git a/Makefile.am b/Makefile.am
index 1d68e6516a..bf9c1d0e91 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -186,7 +186,9 @@ SUFFIXES = .go
 guix_install_go_files = install-nobase_nodist_guilemoduleDATA
 $(guix_install_go_files): install-nobase_dist_guilemoduleDATA
 
-SUBDIRS = doc po
+SUBDIRS = po
+
+include doc.am
 
 if BUILD_DAEMON
 
diff --git a/configure.ac b/configure.ac
index fc6a14b13b..7a7262f967 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,7 +7,7 @@ AC_INIT([GNU Guix], [0.4], [bug-guix@gnu.org], [guix],
 AC_CONFIG_AUX_DIR([build-aux])
 
 AM_INIT_AUTOMAKE([1.12 gnu silent-rules subdir-objects \
- color-tests parallel-tests])
+ color-tests parallel-tests -Woverride])
 
 AC_CONFIG_SRCDIR([guix.scm])
 AC_CONFIG_MACRO_DIR([m4])
diff --git a/doc/Makefile.am b/doc.am
index c40f48ca4a..afd492c605 100644
--- a/doc/Makefile.am
+++ b/doc.am
@@ -1,4 +1,5 @@
 # GNU Guix --- Functional package management for GNU
+# Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
 # Copyright © 2013 Andreas Enge <andreas@enge.fr>
 #
 # This file is part of GNU Guix.
@@ -16,19 +17,19 @@
 # You should have received a copy of the GNU General Public License
 # along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
-info_TEXINFOS = guix.texi
-EXTRA_DIST =                                \
-  fdl-1.3.texi                              \
-  images/bootstrap-graph.dot                \
-  images/bootstrap-graph.eps
+info_TEXINFOS = doc/guix.texi
+EXTRA_DIST +=					\
+  doc/fdl-1.3.texi				\
+  doc/images/bootstrap-graph.dot		\
+  doc/images/bootstrap-graph.eps
 
 infoimagedir = $(infodir)/images
-dist_infoimage_DATA = images/bootstrap-graph.png
+dist_infoimage_DATA = doc/images/bootstrap-graph.png
 
 # Try hard to obtain an image size and aspect that's reasonable for inclusion
 # in an Info or PDF document.
-DOT_OPTIONS =                                           \
-  -Tpng -Gratio=.9 -Gnodesep=.005 -Granksep=.00005      \
+DOT_OPTIONS =						\
+  -Tpng -Gratio=.9 -Gnodesep=.005 -Granksep=.00005	\
   -Nfontsize=9 -Nheight=.1 -Nwidth=.1
 
 .dot.png:
@@ -39,7 +40,9 @@ DOT_OPTIONS =                                           \
 	dot -Teps $(DOT_OPTIONS) < "$<" > "$@.tmp"
 	mv "$@.tmp" "$@"
 
-guix.pdf: images/bootstrap-graph.png
-guix.info: images/bootstrap-graph.png
-guix.ps: images/bootstrap-graph.eps
-
+# We cannot add new dependencies to `doc/guix.pdf' & co. (info "(automake)
+# Extending").  Using the `-local' rules is imperfect, because they may be
+# triggered after the main rule.  Oh, well.
+pdf-local: doc/images/bootstrap-graph.png
+info-local: doc/images/bootstrap-graph.png
+ps-local: doc/images/bootstrap-graph.eps