summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:53 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:25 +0200
commita9f0fabe873f429d47d3a65be3325bccf938ecb2 (patch)
tree8252b96a653bff710d595e3c0bcacd1384e25559
parent5ab8f15b423e70661b3cb9eb16274d2f15cead8d (diff)
downloadguix-a9f0fabe873f429d47d3a65be3325bccf938ecb2.tar.gz
gnu: Add texlive-stealcaps.
* gnu/packages/tex.scm (texlive-stealcaps): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 368159f3f5..4cd8b645ab 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96477,6 +96477,32 @@ characters per line.  This package produces pages with n lines of at most
 m characters each.")
     (license license:lppl1.2+)))
 
+(define-public texlive-stealcaps
+  (package
+    (name "texlive-stealcaps")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/stealcaps/"
+                   "source/latex/stealcaps/"
+                   "tex/latex/stealcaps/")
+             (base32
+              "05lskyv9k4mgkzw08cknbcgbx6d64my7qjc2jljhqgmjsxd4yh07")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments (list #:tex-format "latex"))
+    (home-page "https://ctan.org/pkg/stealcaps")
+    (synopsis "``Steal'' small capitals")
+    (description
+     "This little package is mainly meant to be used when there is a (TrueType or
+OpenType) font that does not provide real small capitals.  As a workaround,
+this package helps to borrow, or steal, the small capitals from another font.
+This might also be useful in the rare case that someone does not like the
+present small capitals, and wants to change them, or likes those from another
+font better.  To achieve the borrowing, one only needs to load the package and
+specify the name of the target font via the from option.")
+    (license license:lppl1.3c)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar