summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-15 12:21:58 +0200
committerMarius Bakke <marius@gnu.org>2022-09-15 16:53:07 +0200
commita9f4fbd31a343a3fa625ae516c50a35a67282142 (patch)
treeca3e425569f257b8eb51a1c7c6e3b2343bd8d31c
parentb0bd3ef9aabbfd45e72ba252a700d71e18e17842 (diff)
downloadguix-a9f4fbd31a343a3fa625ae516c50a35a67282142.tar.gz
gnu: python-pyabbix: Update to 1.2.1.
* gnu/packages/monitoring.scm (python-pyzabbix)[arguments]: Remove patch
phase.  Use pytest instead of nose in check phase.
[native-inputs]: Remove PYTHON-HTTPRETTY and PYTHON-NOSE.  Add
PYTHON-REQUESTS-MOCK and PYTHON-PYTEST.
[propagated-inputs]: Remove PYTHON-SEMANTIC-VERSION.  Add PYTHON-PACKAGING.
-rw-r--r--gnu/packages/monitoring.scm16
1 files changed, 5 insertions, 11 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 47845700ee..e2cdf7c448 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -311,7 +311,7 @@ through a text-based interface.")
 (define-public python-pyzabbix
   (package
     (name "python-pyzabbix")
-    (version "1.0.0")
+    (version "1.2.1")
     (home-page "https://github.com/lukecyca/pyzabbix")
     ;; No tests on PyPI, use the git checkout.
     (source
@@ -321,26 +321,20 @@ through a text-based interface.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "146pv8bj6pv8max1lkm07560b9zcc268c927kff6rcib47qxfnn2"))))
+         "0ad5xac67brmwc3wd0f87pjplly3cqyrz1dp725lzz2hrjgiaqi8"))))
     (build-system python-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'patch
-                    (lambda _
-                      ;; Permit newer versions of httpretty.
-                      (substitute* "setup.py"
-                        (("httpretty<0\\.8\\.7")
-                         "httpretty"))))
                   (replace 'check
                     (lambda* (#:key tests? #:allow-other-keys)
                       (if tests?
-                          (invoke "nosetests")
+                          (invoke "pytest" "-vv" "tests")
                           (format #t "test suite not run~%")))))))
     (native-inputs
      ;; For tests.
-     (list python-httpretty python-nose))
+     (list python-requests-mock python-pytest))
     (propagated-inputs
-     (list python-requests python-semantic-version))
+     (list python-packaging python-requests))
     (synopsis "Python interface to the Zabbix API")
     (description
      "@code{pyzabbix} is a Python module for working with the Zabbix API.")