summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-11-21 20:04:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-11-21 23:17:43 +0100
commitaa33cc29cae391d4208c8a4d879c82025ea4e86c (patch)
treeeb13d25219df47fa0186767f676c54f3ae821e48
parent40590caf3bb96ee36f7def75f292351a5615c795 (diff)
downloadguix-aa33cc29cae391d4208c8a4d879c82025ea4e86c.tar.gz
gnu: idr: Update to 2.0.3.
* gnu/packages/bioinformatics.scm (idr): Update to 2.0.3.
[source]: Add snippet to remove generated code.
-rw-r--r--gnu/packages/bioinformatics.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e13ab73e18..a8d7361ff0 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3050,7 +3050,7 @@ data.  It also provides the bgzip, htsfile, and tabix utilities.")
 (define-public idr
   (package
     (name "idr")
-    (version "2.0.0")
+    (version "2.0.3")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -3059,10 +3059,15 @@ data.  It also provides the bgzip, htsfile, and tabix utilities.")
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "1k3x44biak00aiv3hpm1yd6nn4hhp7n0qnbs3zh2q9sw7qr1qj5r"))))
+                "1rjdly6daslw66r43g9md8znizlscn1sphycqyldzsidkc4vxqv3"))
+              ;; Delete generated C code.
+              (snippet
+               '(begin (delete-file "idr/inv_cdf.c") #t))))
     (build-system python-build-system)
-    (arguments
-     `(#:tests? #f)) ; FIXME: "ImportError: No module named 'utility'"
+    ;; There is only one test ("test_inv_cdf.py") and it tests features that
+    ;; are no longer part of this package.  It also asserts False, which
+    ;; causes the tests to always fail.
+    (arguments `(#:tests? #f))
     (propagated-inputs
      `(("python-scipy" ,python-scipy)
        ("python-sympy" ,python-sympy)