summary refs log tree commit diff
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2023-08-24 13:28:27 +0000
committerRicardo Wurmus <rekado@elephly.net>2023-08-28 10:17:27 +0200
commitaa47077a8b40fa6a19f5e33bc618ce20e9bde6e0 (patch)
tree1a487221c3b07c1ee38d5444f591d98fda3ae117
parent0b0e050415a0fe653a1f901c2c323b6d7c264d52 (diff)
downloadguix-aa47077a8b40fa6a19f5e33bc618ce20e9bde6e0.tar.gz
gnu: Add r-bumpymatrix.
* gnu/packages/bioconductor.scm (r-bumpymatrix): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/bioconductor.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 8b4f88e708..1b62837bbc 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -12979,6 +12979,32 @@ to identify differentially methylated regions in epigenetic epidemiology
 studies.")
     (license license:artistic2.0)))
 
+(define-public r-bumpymatrix
+  (package
+    (name "r-bumpymatrix")
+    (version "1.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "BumpyMatrix" version))
+              (sha256
+               (base32
+                "021xn5d08phmwv6g8a5d4ap5kcf5syhm6vpr784l4k54lflssr5i"))))
+    (properties `((upstream-name . "BumpyMatrix")))
+    (build-system r-build-system)
+    (propagated-inputs (list r-iranges r-matrix r-s4vectors))
+    (native-inputs (list r-knitr))
+    (home-page "https://bioconductor.org/packages/BumpyMatrix")
+    (synopsis "Bumpy matrix of non-scalar objects")
+    (description
+     "This package provides a class and subclasses for storing non-scalar
+objects in matrix entries.  This is akin to a ragged array but the raggedness
+is in the third dimension, much like a bumpy surface--hence the name.  Of
+particular interest is the @code{BumpyDataFrameMatrix}, where each entry is a
+Bioconductor data frame.  This allows us to naturally represent multivariate
+data in a format that is compatible with two-dimensional containers like the
+@code{SummarizedExperiment} and @code{MultiAssayExperiment} objects.")
+    (license license:expat)))
+
 (define-public r-mia
   (package
     (name "r-mia")