summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:27:28 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:49 +0200
commitab0a27520a2cf8066394a479a44ccdf31d801259 (patch)
tree12b2fe71f32290e40f3ef78b37bc8264329b6fa1
parent4d28f9f2dc892e355222321b5ca1fc848c50157b (diff)
downloadguix-ab0a27520a2cf8066394a479a44ccdf31d801259.tar.gz
gnu: Add texlive-karnaugh-map.
* gnu/packages/tex.scm (texlive-karnaugh-map): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 7e0c815b54..aedb1778c1 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4250,6 +4250,28 @@ These macros can typeset Karnaugh-Maps and Veitch-Charts with up to ten
 variables.")
     (license license:lppl1.0+)))
 
+(define-public texlive-karnaugh-map
+  (package
+    (name "texlive-karnaugh-map")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/karnaugh-map/"
+                   "source/latex/karnaugh-map/"
+                   "tex/latex/karnaugh-map/")
+             (base32
+              "01gcffk9vys81b0ad1rxlqnq8i8yflfhby43fr46h7li6p08rx09")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/karnaugh-map")
+    (synopsis "LaTeX package for drawing Karnaugh maps with up to 6 variables")
+    (description
+     "This package draws Karnaugh maps with 2, 3, 4, 5, and 6 variables.  It
+also contains commands for filling the karnaugh map with terms
+semi-automatically or manually.  Last but not least it contains commands for
+drawing implicants on top of the map.")
+    (license license:cc-by-sa3.0)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")