summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:59:45 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:39 +0200
commitab454b91b7c52c3ba0d89c41f60456978088d323 (patch)
tree4e50571cb593d772cfdf960ec9b33ed4ce70dd05
parent4a914f059537033a4135fc3c794d862b34468acc (diff)
downloadguix-ab454b91b7c52c3ba0d89c41f60456978088d323.tar.gz
gnu: Add texlive-repltext.
* gnu/packages/tex.scm (texlive-repltext): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 68fd6a9cd6..be269c56c3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -93945,6 +93945,28 @@ characters.")
 list of subitems.  This helps to find out to which main item a subitem belongs.")
     (license license:lppl)))
 
+(define-public texlive-repltext
+  (package
+    (name "texlive-repltext")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/repltext/"
+                   "source/latex/repltext/"
+                   "tex/latex/repltext/")
+             (base32
+              "0kgkybp0fajswdl0cv8w29nglc2a0g2fxsm4k8z6idn2dkcc2z0c")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/repltext")
+    (synopsis "Control how text gets copied from a PDF file")
+    (description
+     "The @code{repltext} package exposes to LaTeX a relatively obscure PDF
+feature: replacement text.  When replacement text is specified for a piece of
+text, it is the replacement text, not the typeset text that is copied and
+pasted.")
+    (license license:lppl1.3c)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar