summary refs log tree commit diff
diff options
context:
space:
mode:
authorSughosha <sughosha@proton.me>2022-07-01 17:54:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-07-01 19:12:01 +0200
commitaba1ee5553099d45eb22d9ca1f685502146a49d0 (patch)
treea378030123a4330232cbcc8e2eb9a9d38ac03b8c
parent697e75fca59dedfad6cfef4162fff5ab121e940c (diff)
downloadguix-aba1ee5553099d45eb22d9ca1f685502146a49d0.tar.gz
gnu: Add luppp.
* gnu/packages/music.scm (luppp): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/music.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 912f34043f..cc9bae5612 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5055,6 +5055,40 @@ kit.  It provides a patch bay in flow matrix style for audio, MIDI, CV, and
 OSC connections.")
     (license license:artistic2.0)))
 
+(define-public luppp
+  (let ((revision "1")
+        ;; The last release was in 2019.  Since then some build fixes have
+        ;; been added.
+        (commit "23da1497f80dbace48b7807afd3570c57a4d5994"))
+    (package
+      (name "luppp")
+      (version (git-version "1.2.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/openAVproductions/openAV-Luppp")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1rjl7fwnqq1gxa3haw1z0p1mld23i194sc43m03h9isagkwxrx9d"))))
+      (build-system meson-build-system)
+      (inputs
+       (list cairo
+             ntk
+             liblo
+             jack-2
+             libsndfile
+             libsamplerate))
+      (native-inputs (list pkg-config cmake-minimal))
+      (home-page "http://openavproductions.com/luppp/")
+      (synopsis "Live performance tool")
+      (description
+       "Luppp is a music creation tool, intended for live use.  The focus is on real
+time processing and a fast and intuitive workflow.  With extensive MIDI
+mapping support, you can get looping just how you like!")
+      (license license:gpl3+))))
+
 (define-public fabla
   (let ((revision "1")
         ;; The last release was in 2016.  Since then a number of commits have