summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-28 10:14:13 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-11-28 07:59:01 +0200
commitaca7206d7c898dcf68c9bb80eff93fda9bf63fa3 (patch)
tree83c211aa88076b374431983c61fa2f9e9574ee3b
parentb856e842b054c75c83c1e06e0f7141868bb07410 (diff)
downloadguix-aca7206d7c898dcf68c9bb80eff93fda9bf63fa3.tar.gz
gnu: rust-serde-path-to-error-0.1: Update to 0.1.14.
* gnu/packages/crates-io.scm (rust-serde-path-to-error-0.1): Update to
0.1.14.
[cargo-inputs]: Add rust-itoa-1.

Change-Id: Ia9c9b404a4bad5d18ff80ba606ebe8a55c2a1173
-rw-r--r--gnu/packages/crates-io.scm26
1 files changed, 12 insertions, 14 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c2b0eb875a..049104c896 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -66791,28 +66791,26 @@ programs in rust.")
 (define-public rust-serde-path-to-error-0.1
   (package
     (name "rust-serde-path-to-error")
-    (version "0.1.9")
+    (version "0.1.14")
     (source
       (origin
         (method url-fetch)
         (uri (crate-uri "serde-path-to-error" version))
-        (file-name
-          (string-append name "-" version ".tar.gz"))
+        (file-name (string-append name "-" version ".tar.gz"))
         (sha256
-         (base32 "0hbkdhmz82hwx5bxasym776f74jlvnivsx00l4qi7jb3nli4zc16"))))
+         (base32 "0dc31z4bg0jwn69gcqsczbmcy5y4w6r0vdcc4c38vma9x2ycivjb"))))
     (build-system cargo-build-system)
     (arguments
-      `(#:cargo-inputs
-        (("rust-serde" ,rust-serde-1))
-        #:cargo-development-inputs
-        (("rust-serde-derive" ,rust-serde-derive-1)
-         ("rust-serde-json" ,rust-serde-json-1.0.73))))
-    (home-page
-      "https://github.com/dtolnay/path-to-error")
-    (synopsis
-      "Path to the element that failed to deserialize")
+     `(#:cargo-inputs
+       (("rust-itoa" ,rust-itoa-1)
+        ("rust-serde" ,rust-serde-1))
+       #:cargo-development-inputs
+       (("rust-serde-derive" ,rust-serde-derive-1)
+        ("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://github.com/dtolnay/path-to-error")
+    (synopsis "Path to the element that failed to deserialize")
     (description
-      "This package provides a path to the element that failed to deserialize.")
+     "This package provides a path to the element that failed to deserialize.")
     (license (list license:expat license:asl2.0))))
 
 (define-public rust-serde-qs-0.7