summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-02 15:17:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:33 +0200
commitadc02c70c2ee2c8f5b8994e40f653339bff0991e (patch)
treee0f9979974b17eb1d13522a01fa23c2b2b98a7c0
parentda38b23595f4bd031ebf5e942556a2b4338d33f5 (diff)
downloadguix-adc02c70c2ee2c8f5b8994e40f653339bff0991e.tar.gz
gnu: Add texlive-latex-pdfpages.
* gnu/packages/tex.scm (texlive-latex-pdfpages): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index a081f5ec48..4b7caff788 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2041,6 +2041,29 @@ the included graphic.  LaTeX commands can be placed on the graphic at defined
 positions; a grid for orientation is available.")
     (license license:lppl1.0+)))
 
+(define-public texlive-latex-pdfpages
+  (package
+    (name "texlive-latex-pdfpages")
+    (version (number->string %texlive-revision))
+    (source (origin
+              (method svn-fetch)
+              (uri (texlive-ref "latex" "pdfpages"))
+              (sha256
+               (base32
+                "06p5smfq66559ppdnmkl3hp8534x84ywbscimsiir4gllpya3i9h"))))
+    (build-system texlive-build-system)
+    (arguments '(#:tex-directory "latex/pdfpages"))
+    (home-page "http://www.ctan.org/pkg/pdfpages")
+    (synopsis "Include PDF documents in LaTeX")
+    (description
+     "This package simplifies the inclusion of external multi-page PDF
+documents in LaTeX documents.  Pages may be freely selected and it is possible
+to put several logical pages onto each sheet of paper.  Furthermore a lot of
+hypertext features like hyperlinks and article threads are provided.  The
+package supports pdfTeX (pdfLaTeX) and VTeX.  With VTeX it is even possible to
+use this package to insert PostScript files, in addition to PDF files.")
+    (license license:lppl1.3+)))
+
 (define texlive-texmf
   (package
    (name "texlive-texmf")