summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-13 16:10:15 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:10:49 +0200
commitae465393d9fc9b08bfe08647456d0c7432b99e20 (patch)
tree2e2d14316d95b0c08e1b5e11a3e5970a0d5d47d5
parentc2cefad5c875f18ddc2ca9e2c3eddf33c6d1a93b (diff)
downloadguix-ae465393d9fc9b08bfe08647456d0c7432b99e20.tar.gz
gnu: texlive-latex-bookmark -> texlive-bookmark.
* gnu/packages/tex.scm (texlive-bookmark): New variable.
(texlive-latex-bookmark): Deprecate variable.
* gnu/packages/docbook.scm (dblatex): Use new name.
-rw-r--r--gnu/packages/docbook.scm2
-rw-r--r--gnu/packages/tex.scm31
2 files changed, 23 insertions, 10 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 8134191e38..fcd45af32f 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -537,7 +537,7 @@ the in DocBook SGML DTDs.")
      `(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
                                              texlive-anysize
                                              texlive-appendix
-                                             texlive-latex-bookmark
+                                             texlive-bookmark
                                              texlive-latex-changebar
                                              texlive-latex-colortbl
                                              texlive-latex-fancybox
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3c7769ecb7..6f948abcf7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -6514,23 +6514,36 @@ be used, for example, for per chapter/section appendices.  An
 
 (define-deprecated-package texlive-latex-appendix texlive-appendix)
 
-(define-public texlive-latex-bookmark
+(define-public texlive-bookmark
   (package
-    (inherit (simple-texlive-package
-              "texlive-latex-bookmark"
-              (list "/doc/latex/bookmark/"
-                    "/tex/latex/bookmark/")
-              (base32
-               "0xwjdah0p4an0fknvgj9y5phl62sf522z6570pvy6c09hkz0j4h1")
-              #:trivial? #t))
+    (name "texlive-bookmark")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/bookmark/"
+                   "source/latex/bookmark/"
+                   "tex/latex/bookmark/")
+             (base32
+              "111sjwabcbr8ry8fh94ywpzska032y8r4iz4waxa4kf5l3k0p4bs")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (arguments
+     (list #:build-targets #~(list "bookmark.dtx")))
+    (propagated-inputs
+     (list texlive-atenddvi
+           texlive-atveryend
+           texlive-auxhook
+           texlive-hyperref))
     (home-page "https://www.ctan.org/pkg/bookmark")
-    (synopsis "Bookmark (outline) organization for hyperref")
+    (synopsis "Bookmark (outline) organization for @code{hyperref}")
     (description
      "This package implements a new bookmark (outline) organization for the
 @code{hyperref} package.  Bookmark properties such as style and color.  Other
 action types are available (URI, GoToR, Named).")
     (license license:lppl1.3c+)))
 
+(define-deprecated-package texlive-latex-bookmark texlive-bookmark)
+
 (define-public texlive-latex-changebar
   (package
     (name "texlive-latex-changebar")