summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-08 10:31:21 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-08 16:02:33 +0800
commitaf1086774504667ece55c4ca1ea29dbaa9447bb9 (patch)
tree42b62f8f0286ea64e9a588c423837349e86bc628
parent0c75803b7caf9a2b8f4915efcab0ed826510d6af (diff)
downloadguix-af1086774504667ece55c4ca1ea29dbaa9447bb9.tar.gz
gnu: at-spi2-core: Enable tests.
* gnu/packages/gtk.scm (at-spi2-core)[arguments]: Remove #:tests? #f.
  Add #:phases.
-rw-r--r--gnu/packages/gtk.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 98e8c47a12..f7303600b7 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -343,6 +343,13 @@ in the GNOME project.")
              (base32
               "1l3l39mw23zyjlcqidvkyqlr4gwbhplzw2hcv3qvn6p8ikxpf2qw"))))
    (build-system gnu-build-system)
+   (arguments
+    '(#:phases
+      (modify-phases %standard-phases
+        (replace check
+                 ;; Run test-suite under a dbus session.
+                 (lambda _
+                   (zero? (system* "dbus-launch" "make" "check")))))))
    (inputs `(("dbus" ,dbus)
              ("glib" ,glib)
              ("libxi" ,libxi)
@@ -350,9 +357,6 @@ in the GNOME project.")
    (native-inputs
      `(("intltool" ,intltool)
        ("pkg-config" ,pkg-config)))
-   (arguments
-    `(#:tests? #f)) ; FIXME: dbind/dbtest fails; one should disable tests in
-                    ; a more fine-grained way.
    (synopsis "Assistive Technology Service Provider Interface, core components")
    (description
     "The Assistive Technology Service Provider Interface, core components,