summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-11-16 12:32:24 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-11-16 13:03:00 +0200
commitafcf90c60f8a39cfe34bd796f91dde8d1e6e5da2 (patch)
tree9ec445b0be486fdc7e037c6dc8a54e5e3106e27d
parent164c49100db658b8ffaafce1d72c9de39d19d852 (diff)
downloadguix-afcf90c60f8a39cfe34bd796f91dde8d1e6e5da2.tar.gz
gnu: hostapd: Cross compile.
* gnu/packages/admin.scm (hostapd)[arguments]: Use cc-for-target in
make-flags. Add custom flag to use correct pkg-config for target.
-rw-r--r--gnu/packages/admin.scm14
1 files changed, 11 insertions, 3 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 88d0a7901f..f18abcc8e4 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1723,10 +1723,10 @@ command.")
                 "1mrbvg4v7vm7mknf0n29mf88k3s4a4qj6r4d51wq8hmjj1m7s7c8"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases
+     `(#:phases
        (modify-phases %standard-phases
          (replace 'configure
-           (lambda* (#:key outputs #:allow-other-keys)
+           (lambda _
              ;; This is mostly copied from 'wpa-supplicant' above.
              (chdir "hostapd")
              (copy-file "defconfig" ".config")
@@ -1738,6 +1738,14 @@ command.")
       CONFIG_IEEE80211AC=y\n" port)
                (close-port port))
              #t))
+         (add-after 'unpack 'patch-pkg-config
+           (lambda _
+             (substitute* "src/drivers/drivers.mak"
+               (("pkg-config")
+                (or (which "pkg-config")
+                    (string-append ,(%current-target-system)
+                                   "-pkg-config"))))
+             #t))
          (add-after 'install 'install-man-pages
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out  (assoc-ref outputs "out"))
@@ -1754,7 +1762,7 @@ command.")
                          (find-files "." "\\.8"))
                #t))))
 
-      #:make-flags (list "CC=gcc"
+      #:make-flags (list (string-append "CC=" ,(cc-for-target))
                          (string-append "BINDIR=" (assoc-ref %outputs "out")
                                         "/sbin")
                          (string-append "LIBDIR=" (assoc-ref %outputs "out")