summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-23 02:00:00 +0200
commitaffea88cf5e44b969cf599d310323e5855dadc13 (patch)
tree96c52f30e73ea8d1aec81349640fa32355b0d126
parentedf50dec80a75414ec44cf8ec52ee05620fd4a7b (diff)
downloadguix-affea88cf5e44b969cf599d310323e5855dadc13.tar.gz
gnu: bcachefs-tools: Remove obsolete phase & inputs.
* gnu/packages/file-systems.scm (bcachefs-tools)[inputs]:
Remove coreutils-minimal, gawk, and util-linux, needed for an old
version of the mount.bcachefs wrapper that is no longer present.
[arguments]: Remove custom #:phases.  The build system no longer
explicitly builds & installs a shared library.
-rw-r--r--gnu/packages/file-systems.scm18
1 files changed, 2 insertions, 16 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index fe4f483ddc..c3cb96e151 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -649,11 +649,7 @@ from a mounted file system.")
              `(,util-linux "lib")
              lz4
              zlib
-             `(,zstd "lib")
-             ;; Only for mount.bcachefs.sh.
-             coreutils-minimal
-             gawk
-             util-linux))
+             `(,zstd "lib")))
       (home-page "https://bcachefs.org/")
       (synopsis "Tools to create and manage bcachefs file systems")
       (description
@@ -677,17 +673,7 @@ performance and other characteristics.")
      (substitute-keyword-arguments (package-arguments bcachefs-tools)
        ((#:make-flags make-flags)
         #~(append #$make-flags
-              (list "LDFLAGS=-static")))
-       ((#:phases phases)
-        #~(modify-phases #$phases
-            (add-after 'unpack 'skip-shared-library
-              (lambda _
-                (substitute* "Makefile"
-                  ;; Building the shared library with ‘-static’ obviously fails…
-                  (("^((all|install):.*)\\blib\\b(.*)" _ prefix suffix)
-                   (string-append prefix suffix "\n"))
-                  ;; …as does installing a now non-existent file.
-                  ((".*\\$\\(INSTALL\\).* lib.*") ""))))))))
+                  (list "LDFLAGS=-static")))))
     (inputs (modify-inputs (package-inputs bcachefs-tools)
               (prepend `(,eudev "static")
                        `(,keyutils "static")