summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarek Benc <merkur32@gmail.com>2014-09-09 11:39:12 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-09 11:41:55 +0200
commitb005157c9b3a927431b9170b71d828a96507e136 (patch)
tree8f28fc0055f41d079dc42c705f51a06a8a6b0148
parentcf31157fb2ae955f5a996b8831283cb9dcc0cd15 (diff)
downloadguix-b005157c9b3a927431b9170b71d828a96507e136.tar.gz
gnu: Add GNU FriBidi.
* gnu/packages/fribidi.scm: New file.
* gnu-system.am (GNU_SYSTEM_MODULES): Add it.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/fribidi.scm45
2 files changed, 46 insertions, 0 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 86b18b5b8f..8787b76518 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -86,6 +86,7 @@ GNU_SYSTEM_MODULES =				\
   gnu/packages/fontutils.scm			\
   gnu/packages/freeipmi.scm			\
   gnu/packages/ftp.scm				\
+  gnu/packages/fribidi.scm			\
   gnu/packages/games.scm			\
   gnu/packages/gawk.scm				\
   gnu/packages/gcal.scm				\
diff --git a/gnu/packages/fribidi.scm b/gnu/packages/fribidi.scm
new file mode 100644
index 0000000000..eb13aa1c6d
--- /dev/null
+++ b/gnu/packages/fribidi.scm
@@ -0,0 +1,45 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages fribidi)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix licenses))
+
+(define-public fribidi
+  (package
+    (name "fribidi")
+    (version "0.19.6")
+    (source
+      (origin
+        (method url-fetch)
+        (uri
+          (string-append "http://fribidi.org/download/" name "-" version
+                         ".tar.bz2"))
+        (sha256
+          (base32 "0zg1hpaml34ny74fif97j7ngrshlkl3wk3nja3gmlzl17i1bga6b"))))
+
+    (build-system gnu-build-system)
+    (synopsis "Implementation of the Unicode bidirectional algorithm")
+    (description
+     "GNU FriBidi is an implementation of the Unicode Bidirectional
+Algorithm.  This algorithm is used to properly display text in left-to-right
+or right-to-left ordering as necessary.")
+    (home-page "http://fribidi.org/")
+    (license lgpl2.1+)))