summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-03 00:35:46 +0100
committerMarius Bakke <marius@gnu.org>2021-12-05 14:02:09 +0100
commitb0ce8bdb39808ad5b6c4f6763abc286bcb2c6842 (patch)
treea07385da525ec87c21348733bac317a9cf6354a6
parentf457fb19ddbcfcffca26c56193fa385ef69a2b91 (diff)
downloadguix-b0ce8bdb39808ad5b6c4f6763abc286bcb2c6842.tar.gz
gnu: Add python-mistune-next.
* gnu/packages/python-xyz.scm (python-mistune-next): New variable.
-rw-r--r--gnu/packages/python-xyz.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 380a0276a7..a596b00bbb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10259,6 +10259,20 @@ Python.")
 (define-public python2-mistune
   (package-with-python2 python-mistune))
 
+;; 2.0 is not released yet, but some packages have started using it.
+(define-public python-mistune-next
+  (package
+    (inherit python-mistune)
+    (name "python-mistune-next")
+    (version "2.0.0rc1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "mistune" version))
+              (sha256
+               (base32
+                "1nd7iav1ixh9hlj4hxn6lmpava88d86ys8rqm30wgvr7gjlxnas5"))))
+    (native-inputs (list python-nose))))
+
 (define-public python-markdown
   (package
     (name "python-markdown")