summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2023-07-26 20:48:23 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2024-02-24 16:44:01 +0100
commitb0d0c76dbec64d77fbc6e9b1a4f5b4c16e9f6160 (patch)
tree344715e8dc796fa7a53ff05acbe1b0296b5d7cff
parent7b7ab0e4c7f2b24f59af20271bcd78402fa24204 (diff)
downloadguix-b0d0c76dbec64d77fbc6e9b1a4f5b4c16e9f6160.tar.gz
gnu: Add ruby-hashicorp-checkpoint.
* gnu/packages/ruby.scm (ruby-hashicorp-checkpoint): New variable.
-rw-r--r--gnu/packages/ruby.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 311650b6ec..1b72220b33 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -9629,6 +9629,26 @@ follows Ruby conventions and requires little knowledge of REST.")
     (home-page "https://github.com/octokit/octokit.rb")
     (license license:expat)))
 
+(define-public ruby-hashicorp-checkpoint
+  (package
+    (name "ruby-hashicorp-checkpoint")
+    (version "0.1.5")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "hashicorp-checkpoint" version))
+              (sha256
+               (base32
+                "1z6mwzvd7p2wqhmk07dwrhvm0ncgqm7pxn0pr2k025rwsspp9bsd"))))
+    (build-system ruby-build-system)
+    (arguments
+     (list #:tests? #f)) ;; no need to test, useless outside HashiCorp anyway
+    (synopsis "Internal HashiCorp service to check version information")
+    (description "This package is probably useless outside of internal
+HashiCorp use.  It is open source for disclosure and because HashiCorp's open
+source projects must be able to link to it.")
+    (home-page "https://github.com/hashicorp/ruby-checkpoint")
+    (license license:mpl2.0)))
+
 (define-public ruby-vagrant-cloud
   (package
     (name "ruby-vagrant-cloud")