summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:32:10 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commitb12d4f23e07a16e0ebb4be1ecda0adc0f55501aa (patch)
tree9fa35b7f38146dcdb06db95c769e8eca1af8a79e
parentac5d633a960264e6300e492a6cfe8313c8ceddd6 (diff)
downloadguix-b12d4f23e07a16e0ebb4be1ecda0adc0f55501aa.tar.gz
gnu: Add ghc-mime-types.
* gnu/packages/haskell.scm (ghc-mime-types): New variable.
-rw-r--r--gnu/packages/haskell.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 06c1750bba..2ed96342d5 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5632,6 +5632,27 @@ libraries, like OpenSSL.")
 described in @url{http://www.lua.org/}.")
     (license expat)))
 
+(define-public ghc-mime-types
+  (package
+    (name "ghc-mime-types")
+    (version "0.1.0.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://hackage.haskell.org/package/"
+                                  "mime-types/mime-types-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "090z3dp928243amnc6s8g10rk2h2bprk9y138q6wj3cpflzr72pw"))))
+    (build-system haskell-build-system)
+    (propagated-inputs
+     `(("ghc-text" ,ghc-text)))
+    (home-page "https://github.com/yesodweb/wai")
+    (synopsis "Basic MIME type handling types and functions")
+    (description
+     "This library provides basic MIME type handling types and functions.")
+    (license expat)))
+
 (define-public idris
   (package
     (name "idris")