summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:00:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:54 +0200
commitb32a20da079932869218a873a123a2c63e70fc67 (patch)
treeb3d2adf77f03b29ce62cac8ebbf89e389ed7afe8
parent2079afc39b7f6919e25a47a56885a34384f6bd55 (diff)
downloadguix-b32a20da079932869218a873a123a2c63e70fc67.tar.gz
gnu: Add texlive-scrlayer-fancyhdr.
* gnu/packages/tex.scm (texlive-scrlayer-fancyhdr): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index dda2834d84..6a4d1b78bd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -94751,6 +94751,28 @@ that prints out all of the hints.  This generalizes beyond hints; one can create
 scrambled solutions as well, etc.")
     (license license:lppl1.3+)))
 
+(define-public texlive-scrlayer-fancyhdr
+  (package
+    (name "texlive-scrlayer-fancyhdr")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/scrlayer-fancyhdr/"
+                   "source/latex/scrlayer-fancyhdr/"
+                   "tex/latex/scrlayer-fancyhdr/")
+             (base32
+              "1ikr1l1pa33l6v2d3ad4gz2qp3ggldk1f31j49cgfazs6qwnzy0a")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/scrlayer-fancyhdr")
+    (synopsis
+     "Combining package @code{fancyhdr} with KOMA-Script's @code{scrlayer}")
+    (description
+     "This LaTeX package uses KOMA-Script's @code{scrlayer} to redefine the page
+styles of package @code{fancyhdr}.  This allows the combination of features of
+@code{fancyhdr} with features of @code{scrlayer}.")
+    (license license:lppl1.3c)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar