summary refs log tree commit diff
diff options
context:
space:
mode:
authorraingloom <raingloom@riseup.net>2021-11-02 06:36:37 +0000
committerRicardo Wurmus <rekado@elephly.net>2021-12-01 17:03:34 +0100
commitb3a9d079b82fd46c450cd5c79c0fa00a9def386a (patch)
treedacf5c0933e04f0a3122d5c55fc2726f53546a65
parent5ca0042116c05f5d0c3c34211d64cef61bd9c8ff (diff)
downloadguix-b3a9d079b82fd46c450cd5c79c0fa00a9def386a.tar.gz
gnu: Add go-github-com-vividcortex-ewma.
* gnu/packages/golang.scm (go-github-com-vividcortex-ewma): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cc2a4ebc16..e636a957de 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8839,3 +8839,25 @@ JSON for post-processing
     (description
      "Provides a platform-independent way to get atime, mtime, ctime and btime for files.")
     (license license:expat)))
+
+(define-public go-github-com-vividcortex-ewma
+  (package
+    (name "go-github-com-vividcortex-ewma")
+    (version "1.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/VividCortex/ewma")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0whx516l9nm4n41spagb605ry7kfnz1qha96mcshnfjlahhnnylq"))))
+    (build-system go-build-system)
+    (arguments '(#:import-path "github.com/VividCortex/ewma"))
+    (home-page "https://github.com/VividCortex/ewma")
+    (synopsis "Exponentially Weighted Moving Average algorithms for Go")
+    (description
+     "This package implements algorithms for exponentially weighted moving
+averages.")
+    (license license:expat)))