summary refs log tree commit diff
diff options
context:
space:
mode:
authorderekchuank@outlook.com <derekchuank@outlook.com>2022-06-03 19:07:04 +0000
committerLudovic Courtès <ludo@gnu.org>2022-06-07 18:29:13 +0200
commitb42ed3b77c4ff3234f62d6450687991b9772b7e7 (patch)
treef593c585a38174fd9036ea6bfa37e0a549f9a3aa
parentd78478758e11fa67fed29d6b61d6e30843216219 (diff)
downloadguix-b42ed3b77c4ff3234f62d6450687991b9772b7e7.tar.gz
gnu: Add xwhite.
* gnu/packages/xdisorg.scm (xwhite): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/xdisorg.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 6ae6651ac9..d345bc461d 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -54,6 +54,7 @@
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
 ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Derek Chuank <derekchuank@outlook.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1499,6 +1500,35 @@ This is a fork with added support for Wayland using the wlr-gamma-control
 protocol.")
       (license license:gpl3+))))
 
+(define-public xwhite
+  (package
+    (name "xwhite")
+    (version "0.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/derekchuank/xwhite/"
+                                  "releases/download/v" version
+                                  "/xwhite-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0jbnlj5a91ib4anprmylqqnbv9wa73cr7fsc1s54df0a0w5yq8sz"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:tests? #f)) ;No test suite.
+    (native-inputs (list pkg-config))
+    (inputs (list libxrandr))
+    (home-page "https://github.com/derekchuank/xwhite")
+    (synopsis "Adjust the color balance")
+    (description
+     "@command{xwhite} is a command line tool for adjusting the colour
+balance of screen.  It is based on xrandr's gamma correction and brightness adjustment.
+As such, it can only be used for X displays and not Wayland displays.  It is typically
+used for tuning the color balance and color temperature.  It has a similar function as
+@command{redshift -P -g R:G:B -O temperature}, but @command{xwhite} is more flexible
+in that it does not keep the white color fixed, suitable for setting the white color
+to an arbitrary balanced color.")
+    (license license:gpl2)))
+
 (define-public gammastep
   (package
     (name "gammastep")