summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-08 18:51:04 +0200
committerMarius Bakke <marius@gnu.org>2020-06-08 19:01:40 +0200
commitb470122f677d1d11db2e88a34eab5c257ba7b8b8 (patch)
treef48b26f998b37a12949a7b419930224ae842136e
parent4a6974667e838c82ae375c8b9c1b3eaca7a72ac4 (diff)
downloadguix-b470122f677d1d11db2e88a34eab5c257ba7b8b8.tar.gz
gnu: python-odfpy: Update to 1.4.1.
* gnu/packages/python-xyz.scm (python-odfpy): Update to 1.4.1.
[arguments]: Remove #:modules.  Rewrite test phase to use pytest.
[native-inputs]: Add PYTHON-PYTEST.
[propagated-inputs]: Add PYTHON-DEFUSEDXML.
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 94e63d1c74..aaded24af3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12581,27 +12581,26 @@ discovery, monitoring and configuration.")
 (define-public python-odfpy
   (package
     (name "python-odfpy")
-    (version "1.3.3")
+    (version "1.4.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "odfpy" version))
               (sha256
                (base32
-                "1a6ms0w9zfhhkqhvrnynwwbxrivw6hgjc0s5k7j06npc7rq0blxw"))))
+                "1v1qqk9p12qla85yscq2g413l3qasn6yr4ncyc934465b5p6lxnv"))))
     (arguments
-     `(#:modules ((srfi srfi-1)
-                  (guix build python-build-system)
-                  (guix build utils))
-       #:phases
+     `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           ;; The test runner invokes python2 and python3 for test*.py.
-           ;; To avoid having both in inputs, we replicate it here.
            (lambda _
-             (for-each (lambda (test-file) (invoke "python" test-file))
-                       (find-files "tests" "^test.*\\.py$"))
-             #t)))))
+             (setenv "PYTHONPATH" (string-append "./build/lib:"
+                                                 (getenv "PYTHONPATH")))
+             (invoke "pytest" "-vv"))))))
     (build-system python-build-system)
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
+    (propagated-inputs
+     `(("python-defusedxml" ,python-defusedxml)))
     (home-page "https://github.com/eea/odfpy")
     (synopsis "Python API and tools to manipulate OpenDocument files")
     (description "Collection of libraries and utility programs written in