summary refs log tree commit diff
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2018-03-21 03:45:12 +0000
committerLudovic Courtès <ludo@gnu.org>2018-03-31 19:28:31 +0200
commitb50e1c892534644b111b2230cf61662028380d7a (patch)
tree36c1f02b6b932ddaacd9eb893a3caac156136199
parentd199274194f643daab6819c9ee0d4576462610dc (diff)
downloadguix-b50e1c892534644b111b2230cf61662028380d7a.tar.gz
gnu: Add ghc-email-validate.
* gnu/packages/haskell.scm (ghc-email-validate): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 1f6864801b..eb6a36ddec 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9438,4 +9438,33 @@ on the direct-sqlite package, as well as the entire C library, so there are no
 system dependencies.")
     (license license:expat)))
 
+(define-public ghc-email-validate
+  (package
+    (name "ghc-email-validate")
+    (version "2.3.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/"
+             "email-validate/email-validate-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0qvxysiap3r4mi3xff5nsk9qv6diqxfgwj186bypbamzvzlz0lav"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-attoparsec" ,ghc-attoparsec)
+       ("ghc-hspec" ,ghc-hspec)
+       ("ghc-quickcheck" ,ghc-quickcheck)
+       ("ghc-doctest" ,ghc-doctest)))
+    (home-page
+     "https://github.com/Porges/email-validate-hs")
+    (synopsis "Email address validator for Haskell")
+    (description
+     "This Haskell package provides a validator that can validate an email
+address string against RFC 5322.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here