summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:00:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:58 +0200
commitb5415ca0c87533c904e2da1b3c60795702840cee (patch)
treec403aa93826fcf742f4e078d7bd7585b4f1dabd9
parent8ce8729d1254021d53781b976f30a1edfce7da68 (diff)
downloadguix-b5415ca0c87533c904e2da1b3c60795702840cee.tar.gz
gnu: Add texlive-seealso.
* gnu/packages/tex.scm (texlive-seealso): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d3a742c3ca..399af1b7f9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -94948,6 +94948,26 @@ etc.  It supports the asterism symbol, text content, or custom macros as the
 section break mark symbol.")
     (license license:lppl1.3+)))
 
+(define-public texlive-seealso
+  (package
+    (name "texlive-seealso")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/seealso/" "source/latex/seealso/"
+                   "tex/latex/seealso/")
+             (base32
+              "0ibgrrmbdmdbkzahkwgi726zaqz06q9da2102lkyy6r11x7dnvbf")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/seealso")
+    (synopsis "Improve the performance of @code{\\see} macros with MakeIndex")
+    (description
+     "The package amends the @code{\\see} and @code{\\seealso} macros that are used
+in building indexes with MakeIndex, to deal with repetitions, and to ensure
+page numbers are present in the actual index entries.")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar