summary refs log tree commit diff
diff options
context:
space:
mode:
authorSergey Trofimov <sarg@sarg.org.ru>2023-03-26 11:39:02 +0200
committerLudovic Courtès <ludo@gnu.org>2023-04-06 18:34:14 +0200
commitb5a35caeeb23b51eacdc8dd6423fe3c4f56207ef (patch)
tree5dc851827cf724a916554ad5f470a8f87f1b9774
parentcfbd3a3965612874d600c133d08566a7e48556f2 (diff)
downloadguix-b5a35caeeb23b51eacdc8dd6423fe3c4f56207ef.tar.gz
gnu: Add avfs.
* gnu/packages/file-systems.scm (avfs): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/file-systems.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index a62433c01c..d57d407d9c 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -260,6 +260,45 @@ unmaintained---to use the @code{inotify} API instead of the deprecated
 @code{dnotify} to monitor file changes.")
     (license license:gpl2+)))
 
+(define-public avfs
+  (package
+    (name "avfs")
+    (version "1.1.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/avf/avfs/" version
+                                  "/avfs-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1kvjaaj2dlps98alpc8rhnzhk4vriw46f3y7b2h0jq2d21j3p7xd"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags '("--enable-library" "--enable-fuse")))
+    (native-inputs (list pkg-config))
+    (inputs (list xz fuse))
+    (synopsis "Virtual file system that allows browsing of compressed files")
+    (description
+     "AVFS is a FUSE-based filesystem that allows browsing of compressed
+files.  It provides the @command{mountavfs} command that starts a small
+@command{avfsd} daemon.  When a specially formatted path under @file{~/.avfs}
+is accessed, the daemon provides listings and content access on the fly.  The
+canonical form of virtual file name is:
+
+@example
+[basepath]#handler[options][:parameters][/internalpath]
+@end example
+
+Example file names:
+@itemize
+@item @file{~/.avfs/home/user/archive.tar.gz#ugz#utar/path/file}
+@item @file{~/.avfs/#http:localhost|some|path}
+@end itemize
+
+@code{emacs-dired-hacks} has @code{dired-avfs} module which enables seamless
+integration with @code{avfs}.")
+    (home-page "http://avf.sourceforge.net/")
+    (license license:gpl2+)))
+
 (define-public davfs2
   (package
     (name "davfs2")