summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-20 13:07:57 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-20 14:22:36 -0500
commitb6fb9f2c2715c29b14dd52e25d436464267cfbd4 (patch)
tree11044826e335c28c834cb11f29b12453a008bf5b
parent4cb5426ccf1ae4baaa7762591776ab773a1047ab (diff)
downloadguix-b6fb9f2c2715c29b14dd52e25d436464267cfbd4.tar.gz
gnu: Add MooseX-SemiAffordanceAccessor.
* gnu/packages/perl.scm (perl-moosex-semiaffordanceaccessor): New
  variable.
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 3287c4a856..28b064560f 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2259,6 +2259,29 @@ methods to be composed into the classes/roles/instances it's compiled to,
 where plain Moose::Roles would lose the overloading.")
     (license (package-license perl))))
 
+(define-public perl-moosex-semiaffordanceaccessor
+  (package
+    (name "perl-moosex-semiaffordanceaccessor")
+    (version "0.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/D/DR/DROLSKY/"
+                           "MooseX-SemiAffordanceAccessor-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1mdil9ckgmgr78z59p8wfa35ixn5855ndzx14y01dvfxpiv5gf55"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-moose" ,perl-moose)))
+    (home-page "http://search.cpan.org/dist/MooseX-SemiAffordanceAccessor")
+    (synopsis "Name your accessors foo() and set_foo()")
+    (description "This module does not provide any methods.  Simply loading it
+changes the default naming policy for the loading class so that accessors are
+separated into get and set methods.  The get methods have the same name as the
+accessor, while set methods are prefixed with \"_set_\".")
+    (license artistic2.0)))
+
 (define-public perl-moosex-traits-pluggable
   (package
     (name "perl-moosex-traits-pluggable")