summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-07-10 14:32:58 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-07-10 17:39:28 +0200
commitb7e26ec69542c68f4fdbb79c3ad5a193c299cae5 (patch)
tree23b4c717671d231fdd4ecb363005e0c7c07443d4
parentec40227b2c0fefb4decce8c335b13e820e178069 (diff)
downloadguix-b7e26ec69542c68f4fdbb79c3ad5a193c299cae5.tar.gz
gnu: sedsed: Symlink after wrapping.
Drop unused .sedsed-real symlink and avoid sedsed → sedsed.py
→ .sedsed.py-real exec chain.

* gnu/packages/admin.scm (sedsed)[arguments]: Move ‘symlink’ phase
after ‘wrap’.
-rw-r--r--gnu/packages/admin.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 411be40f5b..3a7014c95c 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2492,14 +2492,14 @@ in order to be able to find it.
                ;; Just one file to copy around
                (install-file "sedsed.py" bin)
                #t)))
-         (add-after 'install 'symlink
+         (add-after 'wrap 'symlink
            ;; Create 'sedsed' symlink to "sedsed.py".
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (bin (string-append out "/bin"))
                     (sed (string-append bin "/sedsed"))
                     (sedpy (string-append bin "/sedsed.py")))
-               (symlink  sedpy sed)
+               (symlink sedpy sed)
                #t))))))
     (home-page "http://aurelio.net/projects/sedsed")
     (synopsis "Sed sed scripts")