summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:22:17 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:44 +0200
commitb880116b3bb4df72bf26b9c6774539422a2784d8 (patch)
treee51d1ee5f9890ffeb5a1621bcd79411058a82187
parent0bf8f9873791c9fbb3c0cd0c8831e80b580d6190 (diff)
downloadguix-b880116b3bb4df72bf26b9c6774539422a2784d8.tar.gz
gnu: Add texlive-hep-reference.
* gnu/packages/tex.scm (texlive-hep-reference): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 574f300464..01ffcd2c68 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3941,6 +3941,27 @@ packages, and a selection of others that are useful in High Energy Physics
 papers, etc.")
     (license license:lppl)))
 
+(define-public texlive-hep-reference
+  (package
+    (name "texlive-hep-reference")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/hep-reference/"
+                   "source/latex/hep-reference/"
+                   "tex/latex/hep-reference/")
+             (base32
+              "1ih6l7agq2lks27f8i2z6hqza7s01jwvjcz6kr3vj36ssyvpsqmz")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/hep-reference")
+    (synopsis "Adjustments for publications in High Energy Physics")
+    (description
+     "This package makes some changes to the reference, citation and footnote
+macros to improve the default behavior of LaTeX for High Energy Physics
+publications.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-bibtex8
   (package
     (name "texlive-bibtex8")