summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-02 15:13:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:29 +0200
commitb92ac281e5c56c4cb7a59e99255b336bd3c2d975 (patch)
tree780aeb640872a4839b3b9ba73a19fb0c3c86d589
parent1d3be84e7368d01d34894a3e29f6ba4fe0872da0 (diff)
downloadguix-b92ac281e5c56c4cb7a59e99255b336bd3c2d975.tar.gz
gnu: Add texlive-latex-changebar.
* gnu/packages/tex.scm (texlive-latex-changebar): New variable.
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d15c838748..df3be6fec2 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1746,6 +1746,28 @@ environment is provided which can be used instead of the @code{\\appendix}
 command.")
     (license license:lppl)))
 
+(define-public texlive-latex-changebar
+  (package
+    (name "texlive-latex-changebar")
+    (version (number->string %texlive-revision))
+    (source (origin
+              (method svn-fetch)
+              (uri (texlive-ref "latex" "changebar"))
+              (sha256
+               (base32
+                "1ik4m8pzfsn1grlda6fniqqfwmgj7rfxwg63jdw0p0qv002vc7ik"))))
+    (build-system texlive-build-system)
+    (arguments '(#:tex-directory "latex/changebar"))
+    (home-page "http://www.ctan.org/pkg/changebar")
+    (synopsis "Generate changebars in LaTeX documents")
+    (description
+     "Identify areas of text to be marked with changebars with the
+@code{\\cbstart} and @code{\\cbend} commands; the bars may be coloured.  The
+package uses 'drivers' to place the bars; the available drivers can work with
+@code{dvitoln03}, @code{dvitops}, @code{dvips}, the emTeX and TeXtures DVI
+drivers, and VTeX and pdfTeX.")
+    (license license:lppl)))
+
 (define texlive-texmf
   (package
    (name "texlive-texmf")