summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:59:09 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:25 +0200
commitb93f7bacd47fcb17d936885ecdc43843a941f2b2 (patch)
tree65347c935f447915e18b9e51479a79f46d6ea5e0
parent1a3e535f4802b42e8c82db9ec97791fecf761007 (diff)
downloadguix-b93f7bacd47fcb17d936885ecdc43843a941f2b2.tar.gz
gnu: Add texlive-pxgreeks.
* gnu/packages/tex.scm (texlive-pxgreeks): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index c9359cf51b..6942820f58 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -93229,6 +93229,30 @@ represent sequence of game moves with their associated justification
 pointers.")
     (license license:public-domain)))
 
+(define-public texlive-pxgreeks
+  (package
+    (name "texlive-pxgreeks")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/pxgreeks/"
+                   "source/latex/pxgreeks/"
+                   "tex/latex/pxgreeks/")
+             (base32
+              "1s4bckmniy5paszg6hjqkf7vkj66mc5fpplwlz7xq432k0773xx3")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/pxgreeks")
+    (synopsis "Shape selection for PX fonts Greek letters")
+    (description
+     "The package allows LaTeX maths users of the PX fonts to select the shapes
+(italic or upright) for the Greek lowercase and uppercase letters.  Once the
+shapes for lowercase and uppercase have been selected via a package option,
+the @code{\\other} prefix (e.g., @code{\\otheralpha}) allows using the
+alternate glyph (as in the fourier package).  The @code{pxgreeks} package does
+not constrain the text font that may be used in the document.")
+    (license license:lppl1.3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar