summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:07:21 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:40 +0200
commitb98f56454095f4acc0d3c885433f8966569efdfd (patch)
treec8fb0e0477b995dbd5154d28c2f9302f8cf73720
parentfe83f96235ad9fadb52142877ce990772bbcd34b (diff)
downloadguix-b98f56454095f4acc0d3c885433f8966569efdfd.tar.gz
gnu: byobu: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation.

* gnu/packages/screen.scm (byobu)[inputs]: Add 'bash-minimal'.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/screen.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/screen.scm b/gnu/packages/screen.scm
index 7c16ee239a..026b0042f0 100644
--- a/gnu/packages/screen.scm
+++ b/gnu/packages/screen.scm
@@ -33,6 +33,7 @@
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages hurd)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages perl)
@@ -119,7 +120,8 @@ controlling terminal and attach to it later.")
        (patches (search-patches "byobu-writable-status.patch"))))
     (build-system gnu-build-system)
     (inputs
-     `(("python" ,python-wrapper)       ; for config and session GUIs
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("python" ,python-wrapper)       ; for config and session GUIs
        ("python-newt" ,newt "python")))
     (arguments
      `(#:phases