summary refs log tree commit diff
diff options
context:
space:
mode:
authorThomas Ieong <th.ieong@free.fr>2023-03-04 00:01:54 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-30 22:58:22 +0000
commitb998d582218a9c35828f138cde9da5a2e8fdbea7 (patch)
treea1a5443a44e925d518379b7798bcf171404420c5
parent376bba6030cd418bf26c55422b15f4d22138ddaa (diff)
downloadguix-b998d582218a9c35828f138cde9da5a2e8fdbea7.tar.gz
gnu: Add go-github-com-djherbis-atime.
* gnu/packages/golang-xyz.scm (go-github-com-djherbis-atime): New variable.

Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Change-Id: I320070d68e7f590f830060904f5cbdf59d839d1d
-rw-r--r--gnu/packages/golang-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index c2484aae6b..778868001d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1,4 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Thomas Ieong <th.ieong@free.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -32,6 +33,28 @@
 ;;;
 ;;; Code:
 
+(define-public go-github-com-djherbis-atime
+  (package
+    (name "go-github-com-djherbis-atime")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/djherbis/atime")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0xsz55zpihd9wyrj6qvm3miqzb6x3mnp5apzs0dx1byndhb8adpq"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/djherbis/atime"))
+    (home-page "https://github.com/djherbis/atime")
+    (synopsis "Access Times for files")
+    (description "Package atime provides a platform-independent way to get
+atimes for files.")
+    (license license:expat)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar