summary refs log tree commit diff
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-03-20 13:21:54 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-03-22 22:45:44 +0100
commitb9c150fc9af6704a44218a2d64028a8d5a1e3981 (patch)
tree6bad29060a0b85e2a61b3b2de2340239fc2cb5b5
parent75a95ed95ffded86f41908fae103b3a8385e693e (diff)
downloadguix-b9c150fc9af6704a44218a2d64028a8d5a1e3981.tar.gz
gnu: Add emacs-password-store-otp.
* gnu/packages/emacs-xyz.scm (emacs-password-store-otp): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7ce4bfe31c..a147e81289 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15164,6 +15164,32 @@ close, copy, cut, paste, undo, redo.")
 standard Unix password manager\").")
       (license license:gpl2+))))
 
+(define-public emacs-password-store-otp
+  (package
+    (name "emacs-password-store-otp")
+    (version "0.1.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/volrath/password-store-otp.el")
+             (commit version)))
+       (sha256
+        (base32 "0gb48blvnn6ci2wl45z81p41ny7vbgl610hqy6b2hyr2171qjd60"))
+       (file-name (git-file-name name version))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-password-store" ,emacs-password-store)
+       ("emacs-s" ,emacs-s)))
+    (home-page "https://github.com/volrath/password-store-otp.el")
+    (synopsis
+     "Interact with the @code{pass-otp} extension for @code{pass} from Emacs")
+    (description "This package provides Emacs functions to interact with the
+@code{pass-otp} extension for @code{pass}.  It includes functions to import
+OTP URIs from screenshots of QR codes, and to export them back to QR codes if
+needed.")
+    (license license:gpl3+)))
+
 (define-public emacs-auth-source-pass
   (let ((commit "847a1f54ed48856b4dfaaa184583ef2c84173edf")
         (revision "2"))