summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-02 12:07:11 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:39 +0200
commitb9c65bb18267da400e6b787bcd6aa75a13ccdf67 (patch)
treecc6dad2bbf1262781d6e72de4f6aeed1fe6d56c4
parent177228ccae5b7184a7550d7490c6009718f50e9c (diff)
downloadguix-b9c65bb18267da400e6b787bcd6aa75a13ccdf67.tar.gz
gnu: syndication: Add 'bash' input for 'wrap-program'.
It is required for cross-compilation.

* gnu/packages/syndication.scm
(cawbird)[inputs]: Add 'bash-minimal'.
(giara)[inputs]: Likewise.
(liferea)[inputs]: Likewise.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Change-Id: Iddf5498518ab5e73d04b3b96f0a71db05feed875
-rw-r--r--gnu/packages/syndication.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index f7a6cea697..ed284be26b 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -137,7 +137,8 @@
        ("xmllint" ,libxml2)
        ("xorg-server" ,xorg-server-for-tests)))
     (inputs
-     `(("glib" ,glib)
+     `(("bash" ,bash-minimal) ; for wrap-program
+       ("glib" ,glib)
        ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
        ("gspell" ,gspell)
        ("gstreamer" ,gstreamer)
@@ -201,7 +202,8 @@ cards.")
            (list gtk "bin")
            pkg-config))
     (inputs
-     (list blueprint-compiler-0.4
+     (list bash-minimal
+           blueprint-compiler-0.4
            glib
            gtk
            gtksourceview
@@ -379,7 +381,8 @@ file system, and many more features.")
            pkg-config
            which))
     (inputs
-     (list glib
+     (list bash-minimal
+           glib
            glib-networking
            gnome-keyring
            gsettings-desktop-schemas