summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:49:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:29:34 +0200
commitbad32aeef54f0e09beed64aa5f82f2ca05e298e8 (patch)
tree072e163b9a261ed51644b3876a84eadb93b6761b
parentb113c4c3da6112163986d344b90caec27f294c1b (diff)
downloadguix-bad32aeef54f0e09beed64aa5f82f2ca05e298e8.tar.gz
gnu: Add texlive-oswald.
* gnu/packages/tex.scm (texlive-oswald): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4652000b82..f50980aee7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -20466,6 +20466,30 @@ includes facilities for constructing tables of cases and legislation from
 citations (in conjunction with appropriate indexing packages).")
     (license license:lppl1.3+)))
 
+(define-public texlive-oswald
+  (package
+    (name "texlive-oswald")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/oswald/"
+                   "fonts/enc/dvips/oswald/"
+                   "fonts/map/dvips/oswald/"
+                   "fonts/tfm/public/oswald/"
+                   "fonts/type1/public/oswald/"
+                   "fonts/vf/public/oswald/"
+                   "tex/latex/oswald/")
+             (base32
+              "0ib7k3vgzmsjaxhfb3zcpy3m0yx8p5yyc2hr8x7b8ik7n1ik5sgm")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/oswald")
+    (synopsis "Oswald family of fonts with support for LaTeX and pdfLaTeX")
+    (description
+     "This package provides the Oswald family of fonts, designed by Vernon Adams,
+Kalapi Gajjar, Cyreal, with support for LaTeX and pdfLaTeX.")
+    (license (list license:silofl1.1 license:lppl))))
+
 (define-public texlive-ot-tableau
   (package
     (name "texlive-ot-tableau")