summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-03-19 14:24:39 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2023-03-22 10:35:48 +0100
commitbad546939f3668610c173f931d905176e26c59c4 (patch)
treeba790f154b185479ca5a2be7ba871dd607b48b86
parent121d3adf7151f2832be4be028eb40de3384cedd2 (diff)
downloadguix-bad546939f3668610c173f931d905176e26c59c4.tar.gz
gnu: Add cl-confidence.
* gnu/packages/lisp-check.scm (cl-confidence, ecl-confidence,
  sbcl-confidence): New variables.

Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/lisp-check.scm36
1 files changed, 35 insertions, 1 deletions
diff --git a/gnu/packages/lisp-check.scm b/gnu/packages/lisp-check.scm
index 172f5b3873..c6d5c33728 100644
--- a/gnu/packages/lisp-check.scm
+++ b/gnu/packages/lisp-check.scm
@@ -6,7 +6,7 @@
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019, 2020 Katherine Cox-Buday <cox.katherine.e@gmail.com>
 ;;; Copyright © 2019, 2020, 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
-;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2021, 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2021 Charles Jackson <charles.b.jackson@protonmail.com>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;; Copyright © 2022 André A. Gomes <andremegafone@gmail.com>
@@ -378,6 +378,40 @@ easy to use so that you can quickly start testing.")
 (define-public ecl-clunit2
   (sbcl-package->ecl-package sbcl-clunit2))
 
+(define-public sbcl-confidence
+  (let ((commit "5cbc74715348e12e689afb2d459dcb216c640a44")
+        (revision "0"))
+    (package
+      (name "sbcl-confidence")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/melusina-org/cl-confidence")
+               (commit commit)))
+         (file-name (git-file-name "cl-confidence" version))
+         (sha256
+          (base32 "0zc135rvq2valrw15bh8k6i53v7kk5l7x0kccb1bf7pglc8zgivs"))))
+      (build-system asdf-build-system/sbcl)
+      (arguments
+       `(#:asd-systems '("org.melusina.confidence"
+                         "org.melusina.confidence/testsuite")))
+      (inputs (list sbcl-alexandria))
+      (home-page "https://github.com/melusina-org/cl-confidence")
+      (synopsis "Interactive test framework for Common Lisp")
+      (description
+       "Confidence is a test framework for Common Lisp that focuses on
+simplicty.  It avoids bureaucracy and makes it easy to work interactively,
+without a complicated setup, and with explicit functions and decisions.")
+      (license license:expat))))
+
+(define-public ecl-confidence
+  (sbcl-package->ecl-package sbcl-confidence))
+
+(define-public cl-confidence
+  (sbcl-package->cl-source-package sbcl-confidence))
+
 (define-public sbcl-eos
   (let ((commit "b4413bccc4d142cbe1bf49516c3a0a22c9d99243")
         (revision "2"))