summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-08-15 17:39:11 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-08-15 17:44:25 +0200
commitbb88417fb70f8881d46e2f2e8235a1aa16591a36 (patch)
treeaecf52e8076a5a932fe99ba64ed79c0c75cef225
parent19f1aac0e7405b99c96823dda36e5389f18f64ec (diff)
downloadguix-bb88417fb70f8881d46e2f2e8235a1aa16591a36.tar.gz
gnu: Add r-rcistarget.
* gnu/packages/bioconductor.scm (r-rcistarget): New variable.
-rw-r--r--gnu/packages/bioconductor.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 74620a2cbe..0a0aee7309 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5089,6 +5089,41 @@ by a sparse number of variables, this method can reduce the complexity of
 data, to only emphasize the data that actually matters.")
     (license license:expat)))
 
+(define-public r-rcistarget
+  (package
+    (name "r-rcistarget")
+    (version "1.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "RcisTarget" version))
+       (sha256
+        (base32
+         "133x2vr86ifbk82q08x1c8q19zsk5za7b6qrzz77dhsyf4bhcvpd"))))
+    (properties `((upstream-name . "RcisTarget")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-aucell" ,r-aucell)
+       ("r-biocgenerics" ,r-biocgenerics)
+       ("r-data-table" ,r-data-table)
+       ("r-feather" ,r-feather)
+       ("r-gseabase" ,r-gseabase)
+       ("r-r-utils" ,r-r-utils)
+       ("r-summarizedexperiment" ,r-summarizedexperiment)))
+    (home-page "https://aertslab.org/#scenic")
+    (synopsis "Identify transcription factor binding motifs enriched on a gene list")
+    (description
+     "RcisTarget identifies @dfn{transcription factor binding motifs} (TFBS)
+over-represented on a gene list.  In a first step, RcisTarget selects DNA
+motifs that are significantly over-represented in the surroundings of the
+@dfn{transcription start site} (TSS) of the genes in the gene-set.  This is
+achieved by using a database that contains genome-wide cross-species rankings
+for each motif.  The motifs that are then annotated to TFs and those that have
+a high @dfn{Normalized Enrichment Score} (NES) are retained.  Finally, for
+each motif and gene-set, RcisTarget predicts the candidate target genes (i.e.
+genes in the gene-set that are ranked above the leading edge).")
+    (license license:gpl3)))
+
 (define-public r-cicero
   (package
     (name "r-cicero")