summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-02-16 15:53:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-02-16 15:57:29 +0100
commitbbd92eaa70e66e33ec7c173df25671f572d58337 (patch)
tree3ecd2bb52fae42f7d9d3fc00b9132e3fc6f771bc
parent5e556a19d21fa4554e6264de5f7cbfea64b5781c (diff)
downloadguix-bbd92eaa70e66e33ec7c173df25671f572d58337.tar.gz
gnu: Add r-asioheaders.
* gnu/packages/cran.scm (r-asioheaders): New variable.

Change-Id: If1a82529d7d5b18f1f4d594136a2f4cd388ecbf0
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 43bc7906af..4b739c6dd5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -192,6 +192,29 @@ estimating equations} (GEE) or @dfn{generalized linear mixed effect
 models} (GLMM).")
     (license license:gpl2+)))
 
+(define-public r-asioheaders
+  (package
+    (name "r-asioheaders")
+    (version "1.22.1-2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "AsioHeaders" version))
+       (sha256
+        (base32 "192qxayrpvi02wrqq2h5cjc92aaxrsgw7z32r8qk5imqg3mc0a8n"))))
+    (properties `((upstream-name . "AsioHeaders")))
+    (build-system r-build-system)
+    (home-page "https://github.com/eddelbuettel/asioheaders")
+    (synopsis "Asio C++ header files")
+    (description
+     "Asio is a cross-platform C++ library for network and low-level I/O
+programming that provides developers with a consistent asynchronous model
+using a modern C++ approach.  It is also included in Boost but requires
+linking when used with Boost.  Standalone it can be used header-only (provided
+a recent compiler).  Asio is written and maintained by Christopher
+M. Kohlhoff, and released under the Boost Software License', Version 1.0.")
+    (license license:boost1.0)))
+
 (define-public r-box
   (package
     (name "r-box")