summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-15 16:54:40 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:22 +0200
commitbc64ba55c987e037651f867f04a6532165a8d506 (patch)
treeb1f53bca2946265320b0a1d48d8565d226205b58
parentc24e6ae84c6cd1a4cf7b4b47695277af40fa9d11 (diff)
downloadguix-bc64ba55c987e037651f867f04a6532165a8d506.tar.gz
gnu: Add texlive-revtex.
* gnu/packages/tex.scm (texlive-revtex): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6933a37d80..0d7e88e7f8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10981,6 +10981,26 @@ functions (curves, tangents, integrals, sequences) statistic diagrams plane
 geometry (polygons, circles), arrays and game boards.")
     (license license:lppl1.3c)))
 
+(define-public texlive-revtex
+  (package
+    (name "texlive-revtex")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "bibtex/bst/revtex/" "doc/latex/revtex/"
+                   "source/latex/revtex/" "tex/latex/revtex/")
+             (base32
+              "0w4vmrghnhs8bgpbdp2rzsh4b7hgvldyzkd870wa27k9wk2lk6a1")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/revtex")
+    (synopsis "Styles for various Physics Journals")
+    (description
+     "This package includes styles for American Physical Society, American
+Institute of Physics, and Optical Society of America.  The distribution
+consists of the RevTeX class itself, and several support packages.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-roex
   (package
     (name "texlive-roex")