summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-08-12 21:55:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-08-12 21:55:06 +0200
commitbcdc61bfa1b4800f19c985dd73ad2d5a696e5307 (patch)
tree4eb6f2478345747be92611e50968c18fccbfa459
parentc9a16728410f11f4bd9b49632ca2b13df849ecdc (diff)
downloadguix-bcdc61bfa1b4800f19c985dd73ad2d5a696e5307.tar.gz
gnu: tophat: Hide default GCC.
* gnu/packages/bioinformatics.scm (tophat)[arguments]: Add build phase
"hide-default-gcc".
-rw-r--r--gnu/packages/bioinformatics.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 57bfcf8207..2f4a2b1461 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1683,6 +1683,17 @@ genome (2.9 GB for paired-end).")
      '(#:parallel-build? #f             ; not supported
        #:phases
        (modify-phases %standard-phases
+         (add-after 'set-paths 'hide-default-gcc
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((gcc (assoc-ref inputs "gcc")))
+               ;; Remove the default GCC from CPLUS_INCLUDE_PATH to prevent
+               ;; conflicts with the GCC 5 input.
+               (setenv "CPLUS_INCLUDE_PATH"
+                       (string-join
+                        (delete (string-append gcc "/include/c++")
+                                (string-split (getenv "CPLUS_INCLUDE_PATH") #\:))
+                        ":"))
+               #t)))
          (add-after 'unpack 'use-system-samtools
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "src/Makefile.in"
@@ -1705,7 +1716,7 @@ genome (2.9 GB for paired-end).")
                (("#include <sam.h>") "#include <samtools/sam.h>"))
              #t)))))
     (native-inputs
-     `(("gcc" ,gcc-5))) ;; doesn't build with later versions
+     `(("gcc@5" ,gcc-5))) ;; doesn't build with later versions
     (inputs
      `(("boost" ,boost)
        ("bowtie" ,bowtie)