summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2024-08-15 18:40:16 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:45 +0200
commitbd2406d9d518148b54a9c3878003dbe3323e15c7 (patch)
treedd251d41af4541e35b55938a8ffea3cf8cb183f4
parentdf38aacc02d3a6fb05717430f0d3e3bb43421d9d (diff)
downloadguix-bd2406d9d518148b54a9c3878003dbe3323e15c7.tar.gz
gnu: glibc-bootstrap: Update i586-gnu variant.
‘glibc-stripped-2.39-i586-pc-gnu.tar.xz’ was built from x86_64-linux
from the previous commit with:

  ./pre-inst-env guix build --target=i586-pc-gnu \
     -e '((@@ (gnu packages make-bootstrap) %glibc-bootstrap-tarball))'

This updated variant is necessary to match newer GNU Mach headers, which
are themselves necessary for the newer Hurd.

Fixes <https://issues.guix.gnu.org/72315>.

* gnu/packages/bootstrap.scm (%bootstrap-glibc): Update i586-gnu
variant.

Change-Id: I2d770e8001896059e1f27e50f7a4ddf15e4b5812
-rw-r--r--gnu/packages/bootstrap.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index a36bb289cd..3743abf9fe 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012-2020, 2024 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2014, 2015, 2018, 2019 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2017, 2020, 2024 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018, 2020, 2022 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
@@ -37,7 +37,7 @@
                 #:select (raw-derivation derivation-input derivation->output-path))
   #:use-module (guix utils)
   #:use-module ((guix build utils) #:select (elf-file?))
-  #:use-module ((guix gexp) #:select (lower-object))
+  #:use-module ((guix gexp) #:select (lower-object local-file))
   #:use-module (guix monads)
   #:use-module (guix memoization)
   #:use-module (guix i18n)
@@ -770,7 +770,7 @@ $out/bin/guile --version~%"
                                       ("powerpc64le-linux"
                                        "/20210106/glibc-stripped-2.31-powerpc64le-linux-gnu.tar.xz")
                                       ("i586-gnu"
-                                       "/20200326/glibc-stripped-2.31-i586-pc-gnu.tar.xz")
+                                       "/20240816/glibc-stripped-2.39-i586-pc-gnu.tar.xz")
                                       ("powerpc-linux"
                                        "/20200923/glibc-2.32.tar.xz")
                                       ("riscv64-linux"
@@ -800,7 +800,7 @@ $out/bin/guile --version~%"
                           "0d9x80vm7ca1pd2whcmpm1h14zxpb58kqajlxlwffzm04xfsjnxm"))
                         ("i586-gnu"
                          (base32
-                          "14ddm10lpbas8bankmn5bcrlqvz1v5dnn1qjzxb19r57vd2w5952"))
+                          "0x2x6w611k6v9qdabacawamw2475p04hm3s0q95xcg063wjq4ig2"))
                         ("powerpc-linux"
                          (base32
                           "0smmssyjrlk5cvx49586smmk81gkwff0i6r91n4rir4jm6ba25sb"))