summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolò Balzarotti <anothersms@gmail.com>2019-12-11 09:19:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-11 12:08:19 +0100
commitbd538a031e34fbec0dc5af2e576dd679f6836675 (patch)
tree0ff751a37a8e22150d49bf5f2e3c68d51247d3b4
parentf00da07471d3f1e01df07cb1af970faf50e6d622 (diff)
downloadguix-bd538a031e34fbec0dc5af2e576dd679f6836675.tar.gz
gnu: Add r-cyclocomp.
* gnu/packages/cran.scm (r-cyclocomp): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b3bde41d79..73626cb4d2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14740,6 +14740,34 @@ regular expressions from human readable expressions")
 @code{XPath}, and is easier to manipulate in general.")
     (license license:expat)))
 
+(define-public r-cyclocomp
+  (package
+    (name "r-cyclocomp")
+    (version "1.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "cyclocomp" version))
+       (sha256
+        (base32
+         "0gky3svk02wiajw7nfjh30684h3qxili4bvsab0m7b6cggw6bgyd"))))
+    (properties `((upstream-name . "cyclocomp")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-callr" ,r-callr)
+       ("r-crayon" ,r-crayon)
+       ("r-desc" ,r-desc)
+       ("r-remotes" ,r-remotes)
+       ("r-withr" ,r-withr)))
+    (home-page "https://github.com/MangoTheCat/cyclocomp")
+    (synopsis "Cyclomatic complexity of R code")
+    (description
+     "Cyclomatic complexity is a software metric, used to indicate the
+complexity of a program.  It is a quantitative measure of the number of
+linearly independent paths through a program's source code.  This package
+provides tools to compute this metric.")
+    (license license:expat)))
+
 (define-public r-sctransform
   (package
     (name "r-sctransform")