summary refs log tree commit diff
diff options
context:
space:
mode:
authorAllan Adair <allan@adair.no>2024-01-24 10:18:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-02-12 09:08:11 +0100
commitbd9da702123ab746bd43de5b0fc0c129874b15aa (patch)
treee8dd2e358849021c17700bfbb1a808d1fbbc2ef7
parentc4372f7ebfac17236299346fe60c6ca125336b1f (diff)
downloadguix-bd9da702123ab746bd43de5b0fc0c129874b15aa.tar.gz
gnu: vpn-slice: Include required inputs "iproute" and "iptables".
vpn-slice expects commands "ip" and "iptables" to be found according to FHS
paths.

* gnu/packages/vpn.scm (vpn-slice)[arguments]: Include inputs "iproute" and
"iptables" and patch "vpn_slice/linux.py" to use correct locations in the
store.

Change-Id: Ia06e2bb99f060108cc0758e89174294bcbb2848d
Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/vpn.scm29
1 files changed, 21 insertions, 8 deletions
diff --git a/gnu/packages/vpn.scm b/gnu/packages/vpn.scm
index 02c1ee1043..0070eaab6f 100644
--- a/gnu/packages/vpn.scm
+++ b/gnu/packages/vpn.scm
@@ -23,6 +23,7 @@
 ;;; Copyright © 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
 ;;; Copyright © 2022 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2024 Allan Adair <allan@adair.no>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1245,17 +1246,29 @@ L2TP allows you to tunnel PPP over UDP.")
   (package
     (name "vpn-slice")
     (version "0.16.1")
-    (source (origin
-              (method url-fetch)
-              (uri (pypi-uri "vpn-slice" version))
-              (sha256
-               (base32
-                "1anfx4hn2ggm6sbwqmqx68s3l2rjcy4z4l038xqb440jnk8jvl18"))))
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "vpn-slice" version))
+       (sha256
+        (base32 "1anfx4hn2ggm6sbwqmqx68s3l2rjcy4z4l038xqb440jnk8jvl18"))))
     (build-system python-build-system)
-    (inputs (list python-dnspython python-setproctitle))
+    (arguments
+     (list
+      #:phases
+      '(modify-phases %standard-phases
+         (add-after 'unpack 'patch-FHS-file-names
+           (lambda _
+             (substitute* "vpn_slice/linux.py"
+               (("/sbin/iptables")
+                (which "iptables"))
+               (("/sbin/ip")
+                (which "ip"))))))))
+    (inputs (list python-dnspython python-setproctitle iproute iptables))
     (home-page "https://github.com/dlenski/vpn-slice")
     (synopsis "Split tunneling replacement for vpnc-script")
-    (description "vpn-slice is a replacement for @command{vpnc-script} used by
+    (description
+     "vpn-slice is a replacement for @command{vpnc-script} used by
 @code{openconnect} and @code{vpnc}.  Instead of trying to copy the behavior of
 standard corporate VPN clients, which normally reroute all your network
 traffic through the VPN, vpn-slice tries to minimize your contact with an