summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2018-08-31 07:04:17 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2018-08-31 07:04:17 +0200
commitbe4c63f48406006ded84511cf82f10b9f5400f7c (patch)
tree6c8e631aa9766006af6c975148a65261c1811115
parent0c048c11a492dda58cf1c8445bcfefe0199d7e0c (diff)
downloadguix-be4c63f48406006ded84511cf82f10b9f5400f7c.tar.gz
gnu: mame: Update to 0.201.
* gnu/packages/emulators.scm (mame): Update to 0.201.
[arguments]: Remove unnecessary fix.
-rw-r--r--gnu/packages/emulators.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index 141423d7bf..919392c72f 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -1175,7 +1175,7 @@ play them on systems for which they were never designed!")
 (define-public mame
   (package
     (name "mame")
-    (version "0.200")
+    (version "0.201")
     (source
      (origin
        (method git-fetch)
@@ -1185,7 +1185,7 @@ play them on systems for which they were never designed!")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0ddw8635hdm21lgpf13k1vhfywy3460rwciv93vrqmpkq2dvpmib"))
+         "00whiig4ld3d4fkl34q48vlf28ygvvp5g7fp0rb5n31ymhl4kajk"))
        (modules '((guix build utils)))
        (snippet
         ;; Remove bundled libraries.
@@ -1211,17 +1211,6 @@ play them on systems for which they were never designed!")
        #:tests? #f                      ;no test in regular release
        #:phases
        (modify-phases %standard-phases
-         ;; Add missing include lines for "fmin" and "ceil" functions.
-         ;; Reported upstream.  Will be fixed in 0.201.
-         (add-after 'unpack 'add-missing-include
-           (lambda _
-             (substitute* "src/devices/cpu/mips/mips3.cpp"
-               (("#include \"ps2vu.h\"" all)
-                (string-append all "\n#include <cmath>")))
-             (substitute* "src/devices/cpu/mips/ps2vif1.cpp"
-               (("#include \"ps2vif1.h\"" all)
-                (string-append all "\n#include <cmath>")))
-             #t))
          (delete 'configure)
          (add-after 'build 'build-documentation
            (lambda _ (invoke "make" "-C" "docs" "man" "info")))