summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:02:08 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:31 +0200
commitbecf40315cfde507ab10b6caf96d19fbf0b54a32 (patch)
treed36c2af93b51127d1656cc0569b6157eadae5666
parent244aa17dba42a30d51e239dc5af74a4ce48ee1e1 (diff)
downloadguix-becf40315cfde507ab10b6caf96d19fbf0b54a32.tar.gz
gnu: Add texlive-subfloat.
* gnu/packages/tex.scm (texlive-subfloat): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 289024962f..a573c5c67e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96769,6 +96769,29 @@ sub-figures (or tables or text).  The sub-figures are placed left-to-right,
 top-to-bottom.")
     (license license:lppl)))
 
+(define-public texlive-subfloat
+  (package
+    (name "texlive-subfloat")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/subfloat/"
+                   "source/latex/subfloat/"
+                   "tex/latex/subfloat/")
+             (base32
+              "119p6vf8ai1sfhma3aplkyldiypjnfc6qj08xnij69szk6yq6gdv")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/subfloat")
+    (synopsis "Sub-numbering for figures and tables")
+    (description
+     "This package enables sub-numbering of floats (figures and tables) similar to
+the @code{subequations} environment of the @code{amsmath} package.  The
+@code{subfloat} package is not to be confused with the @code{subfig} package
+which generates sub-figures within one normal figure, and manages their
+placement; @code{subfloat} only affects captions and numbering.")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar