summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-05-03 17:56:27 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-05-03 17:57:23 +0800
commitbfe513eeb39a3325d1d8a6e23121f7ab4165a874 (patch)
tree6b36fe73c1b7545408fcd7a369bed02974ee6f55
parenta60ca78823ba737b541f5b59b47925a848bb7dd5 (diff)
downloadguix-bfe513eeb39a3325d1d8a6e23121f7ab4165a874.tar.gz
gnu: python-markdownify: Update to 0.11.6, fix build.
* gnu/packages/markup.scm (python-markdownify): Update 0.11.6.
[arguments]: Run tests using 'pytest'.
[propagated-inputs]: Remove python-flake8.
-rw-r--r--gnu/packages/markup.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 9162b008e0..cdd9891352 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -310,19 +310,25 @@ GitHub cmark fork (@code{cmark-gfm}).")
 (define-public python-markdownify
   (package
     (name "python-markdownify")
-    (version "0.10.1")
+    (version "0.11.6")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "markdownify" version))
        (sha256
         (base32
-         "0msvrsgq9jigbgg7r7iq7ql5bgslmbxd8sq0nmpbxrjwqypgs7w2"))))
+         "1zlvwiapcvzaz7nmviffz3q147h1skf2amh83npqwk4z1h7296q0"))))
     (build-system python-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (replace 'check
+                 (lambda* (#:key tests? #:allow-other-keys)
+                   (when tests? (invoke "pytest" "-v" "tests")))))))
     (native-inputs
      (list python-pytest))
     (propagated-inputs
-     (list python-flake8 python-beautifulsoup4 python-six))
+     (list python-beautifulsoup4 python-six))
     (home-page
      "https://github.com/matthewwithanm/python-markdownify")
     (synopsis "Converts HTML to Markdown")