summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-09-01 13:12:48 +0200
committerMarius Bakke <marius@gnu.org>2020-09-22 18:41:55 +0200
commitbfe8c030e4b1d7c20391af600108d3817b273856 (patch)
tree9c4fa7e28855a7cd372ff91ac8a2365f98fd1948
parent76cd38f12e87513e68d55edc2d75db2402517b40 (diff)
downloadguix-bfe8c030e4b1d7c20391af600108d3817b273856.tar.gz
gnu: python-django-picklefield: Update to 3.0.1.
* gnu/packages/django.scm (python-django-picklefield): Update to 3.0.1.
[source]: Switch to GIT-FETCH.
[arguments]: New field.
[native-inputs]: Remove.
-rw-r--r--gnu/packages/django.scm21
1 files changed, 15 insertions, 6 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index 84c32b6fbd..d61a89f5c1 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -683,18 +683,27 @@ conn_max_age argument to easily enable Django’s connection pool.")
 (define-public python-django-picklefield
   (package
     (name "python-django-picklefield")
-    (version "2.1.1")
+    (version "3.0.1")
+    (home-page "https://github.com/gintas/django-picklefield")
+    ;; Use a git checkout because the PyPI release lacks tests.
     (source
       (origin
-        (method url-fetch)
-        (uri (pypi-uri "django-picklefield" version))
+        (method git-fetch)
+        (uri (git-reference
+              (url home-page)
+              (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
         (sha256
          (base32
-          "0imncys5s3vsy2q79nn7k5d670da1xgmcr9gmhn06fry6ibf39b7"))))
+          "0ni7bc86k0ra4pc8zv451pzlpkhs1nyil1sq9jdb4m2mib87b5fk"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (replace 'check
+                    (lambda _
+                      (invoke "python" "-m" "django" "test" "-v2"
+                              "--settings=tests.settings"))))))
     (propagated-inputs `(("python-django" ,python-django)))
-    (native-inputs `(("python-tox" ,python-tox)))
-    (home-page "https://github.com/gintas/django-picklefield")
     (synopsis "Pickled object field for Django")
     (description "Pickled object field for Django")
     (license license:expat)))