summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-03-11 15:26:48 -0400
committerLeo Famulari <leo@famulari.name>2020-03-11 15:27:17 -0400
commitc03fc422b933c97da088bbcb76236b119f29587c (patch)
tree0eb46d8d37f084e49428d9d6164c71aee3cb69bb
parentdfe15d9919ba74b28ec8adca8a88cc02ef8c43af (diff)
downloadguix-c03fc422b933c97da088bbcb76236b119f29587c.tar.gz
gnu: lpd8editor: Remove package.
This package has not built successfully in several months.

* gnu/packages/music.scm (lpd8editor): Remove variable.
-rw-r--r--gnu/packages/music.scm36
1 files changed, 0 insertions, 36 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 8914db3b0e..3690af83d7 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4615,42 +4615,6 @@ discard bad quality ones.
 @end itemize\n")
       (license license:expat))))
 
-(define-public lpd8editor
-  (package
-    (name "lpd8editor")
-    (version "0.0.13")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                     (url "https://github.com/charlesfleche/lpd8editor.git")
-                     (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "0lsz3v493ilq2zr016m7kvymrplxd0n3pqv1pjglpq1h7sjw9764"))))
-    (build-system gnu-build-system)
-    (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'setenv
-           (lambda _
-             (setenv "INSTALL_PREFIX"
-                     (assoc-ref %outputs "out"))))
-         (delete 'configure) ; no configure script
-         (add-before 'build 'qmake
-           (lambda _ (invoke "qmake"))))))
-    (native-inputs
-     `(("pkg-config" ,pkg-config)))
-    (inputs
-     `(("alsa" ,alsa-lib)
-       ("qtbase" ,qtbase)
-       ("qtsvg" ,qtsvg)))
-    (synopsis "Graphical editor for the Akai LPD8 MIDI controller")
-    (description "lpd8editor is a graphical patch editor for the Akai LPD8 MIDI
-controller.")
-    (home-page "https://github.com/charlesfleche/lpd8editor")
-    (license license:expat)))
-
 (define-public fmit
   (package
     (name "fmit")