summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2023-09-11 22:07:45 +0800
committerMarius Bakke <marius@gnu.org>2023-09-22 01:29:17 +0800
commitc097775401b35b963a47e7353584906d9dda2782 (patch)
tree2a264d95441426c9eba655cd6d4f9698c64591ad
parentb2467d2354b8d0b43e53f15d8c349489110a1a97 (diff)
downloadguix-c097775401b35b963a47e7353584906d9dda2782.tar.gz
gnu: Add python-tracerite.
* gnu/packages/python-xyz.scm (python-tracerite): New variable.
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 51196e71c7..42ab90c608 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23337,6 +23337,26 @@ stack traces of Python programs.  It exactly mimics the behavior of the Python
 interpreter when it prints a stack trace.")
     (license license:psfl)))
 
+(define-public python-tracerite
+  (package
+    (name "python-tracerite")
+    (version "1.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "tracerite" version))
+              (sha256
+               (base32
+                "0jwy5wwl0rcsgnx7hhq4z7ji3lx271sar4v2a1rmyh5vsj7sn784"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-setuptools-scm))
+    (propagated-inputs (list python-html5tagger))
+    (home-page "https://github.com/sanic-org/tracerite")
+    (synopsis "Human-readable HTML tracebacks")
+    (description
+     "@code{tracerite} converts Python tracebacks into useful error messages
+in human-readable HTML format.")
+    (license license:unlicense)))
+
 (define-public python-ratelimiter
   (package
     (name "python-ratelimiter")