summary refs log tree commit diff
diff options
context:
space:
mode:
authorTroy Sankey <sankeytms@gmail.com>2017-10-10 22:55:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-10-10 23:09:41 +0200
commitc1578ad0632ecb4567d502ee9144ed6bb72ebb60 (patch)
tree3d034010691f90c3f0bfbaa4eb07b472f1dfdf92
parent0cd83b4e000df50f93f00b3b77691852afe57b7f (diff)
downloadguix-c1578ad0632ecb4567d502ee9144ed6bb72ebb60.tar.gz
gnu: python-twisted: Update to 17.1.0.
* gnu/packages/python.scm (python-twisted): Update to 17.1.0.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/python.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1414979378..84e9ece25d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11745,13 +11745,13 @@ format.")
 (define-public python-twisted
   (package
     (name "python-twisted")
-    (version "16.2.0")
+    (version "17.1.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "Twisted" version ".tar.bz2"))
               (sha256
                (base32
-                "0ydxrp9myw1mvsz3qfzx5579y5llmqa82pxvqchgp5syczffi450"))))
+                "1p245mg15hkxp7hy5cyq2fgvlgjkb4cg0gwkwd148nzy1bbi3wnv"))))
     (build-system python-build-system)
     (arguments
      '(#:tests? #f)) ; FIXME: Some tests are failing.
@@ -11761,7 +11761,10 @@ format.")
        ;;     (lambda _
        ;;       (zero? (system* "./bin/trial" "twisted")))))
     (propagated-inputs
-     `(("python-zope-interface" ,python-zope-interface)))
+     `(("python-zope-interface" ,python-zope-interface)
+       ("python-incremental" ,python-incremental)
+       ("python-constantly" ,python-constantly)
+       ("python-automat" ,python-automat)))
     (home-page "https://twistedmatrix.com/")
     (synopsis "Asynchronous networking framework written in Python")
     (description